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Expander v4 – hands-on session:

Downloading data files:

Go to http://acgt.cs.tau.ac.il/expander/help/handsOn08.html and download the data for the session (extract the zip file into D:/MA Course/ExpanderData/). 

Launching Expander: 

Double click on the Expander.bat icon.

1. Human serum dataset analysis:

In this section, we will analyze high-density oligonucleotide array data, which contains expression profiles measured in several time points after serum stimulation of human cell line. In this experiment expression levels were recorded using Affymetrix Human Genome U133 Plus 2.0 arrays.

1.1. Loading the data: 

We will load the gene expression data matrix and an ID conversion file. The conversion file maps each Affymetrix probe ID in the data file to its corresponding official gene ID (Entrez-Gene IDs).
· From the “File” menu, select “New Session” ( ”Expression Data” ( ”Tabular Data File”.

· In the “Load Study” dialog box, make sure the Organism is set to “Human”. Use the “Browse” buttons to load the expression data file and the ID conversion file from the following directories:  

            Data file:  D:/MA Course/ExpanderData/serum.human.txt 

 
Conversion file: D:/MA Course/ExpanderData/HGU133P2_affyids2Geneids.txt

· Set the “Data type” to “Oligonucleotide array”.

· Press the “OK” button.

· Look at the resulting box plots and identify the array that is biased toward the lower intensities.

1.2. Normalizing the data:  

Normalization of the data is required in order to remove systematic variation, i.e. variation arising from reasons other than biological differences between RNA samples.
· From the “Preprocessing” menu, select “Normalization” ( “View Scatter Plots”. A dialog box will appear. 

· In the dialog box, select “t0” as the Base condition and “t2” as the Test condition. The option "simple plot" is selected by default.

· Press the “OK” button. 

· Look at the resulting plot. For normalized data, points should be scattered around the y=x line (marked on the scatter plot). If a systematic bias exists in the data, the scatter plot is shifted from the x=y diagonal. 

· From the “Preprocessing” menu, select “Normalization” ( ”Quantile”.  

· Press “OK” in the “Confirm operation” dialog box. A new data sheet will appear. 

· Look at “Preprocessed Data Box-plot” in the data view (bottom right), and compare it to the “Raw Data Box-plot” (top right).

· Now, after we have normalized the data, we'll re-create the scatter plot. From the “Preprocessing” menu, select “Normalization” ( “View Scatter Plots”. 

· In the dialog box, select “t0” as the Base condition and “t2” as the Test condition.

· Press the “OK” button. 

· Look at the resulting plot (Data Scatter 2.1) in comparison to the one generated before normalization (Data Scatter 1.1). You can dock a view into a separate frame by selecting “Dock into external frame” from the “Options” menu (or right-clicking on the scatter plot tab, and choosing "Dock into external frame").

1.3. Filtering the data:  

· Make sure that Data Sheet 2 is active (the one with normalized data). If not, press on its tab to be activated. 

· From the “Preprocessing” menu, select “Filter Probes” ( ”Fold Change”.

· Press “OK” on the “Confirm operation” dialog box. A new data sheet (Data Sheet 3) will appear along with the “Data Fold-Change Filter” dialog box. 

· Set the fold-change factor to 3, leave the 'base condition' as "t0"; This will select all the probes whose expression levels were changed (up- or down-regulated) by at least a factor of 3 with respect to their expression level in the untreated sample (t0). 

Press “Ok”. 

· A message box indicating the number of probes that will remain appears (750 probes). Click ”Yes”.

1.4. Standardizing the expression patterns:

In order to bring all expression levels to the same scale, we will apply standardization to the data.

· From the “Preprocessing” menu, select “Standardization” ( ”Mean 0 and Variance 1”.  

· Look at the Y-axis values in the “Preprocessed Data Box-plots” at the right side of the data sheet (demonstrating the change in data scale after standardization). 

· Select the “Preprocessed Expression Matrix” tab at the right side of the data sheet to view the standardized expression values. 

1.5. Clustering the data:

The goal of clustering is to partition the genes into distinct sets such that genes that share common expression patterns are assigned to the same cluster, while genes assigned to different clusters should have "non-similar" expression patterns. Here we will use the CLICK algorithm to perform the clustering.

· From the “Grouping” menu, select “Clustering” ( “CLICK”. Press “Ok” in the “CLICK” dialog box. 

· After running the “CLICK” algorithm, the results will be displayed in a new tab.

· Click on the pattern chart of cluster #1. The genes assigned to this cluster will appear in the list on the right pane (which may be hidden, use the mouse to expose it). 

· Click on the “Gene Symbol” column header of the list to sort it according to the gene symbols. Scroll down the list to get an impression of its content. 

· Click on a row in the list and look at the displayed pattern on the bottom (repeat this for a few probes).

· Select the “Cluster Matrix” tab to view the expression matrix of cluster #1.

· Repeat the previous steps for another cluster of your choice.

1.6. Identifying enriched GO categories within clusters:

· From the “Group Analysis” menu, select “Functional Analysis” (  “TANGO”.  In the “Functional Analysis” dialog box select “CLICK 3.1” as the clustering on which analysis is to be performed. Press the “OK” button. The default Background set is Original Data (that is, the data you loaded, before filtering genes out).

· Look at the resulting display. In which sets (clusters) has functional enrichment been detected? 

· Click on one of the columns in the enrichment diagram of set 2. The “Enrichment Info” dialog box will appear.

· In the “Enrichment info” dialog box, click on one of the Gene IDs in the table. An internet browser will open, containing information about the corresponding gene, from the Enterz-Gene site. 

· Go back to the CLICK 3.1 solution tab. Open the content of the clusters for which a GO enrichment was identified by clicking on the corresponding row in the clusters table. The panel on the right now contains an additional tab with the title: CLICK 3.1 GO Enrich.1, which contains the GO enrichment diagram and information corresponding to the active cluster.

1.7. Identifying enriched TF Binding sites within clusters:

· From the “Group Analysis” menu, select “Promoter Analysis” ( “PRIMA”.  In the “Promoter Analysis” dialog box select “CLICK 3.1” as the clustering on which analysis is to be performed. Press the “OK” button. The analysis might take a few minutes. 

· Look at the resulting display. In which sets (clusters) has TF binding sites enrichment been detected? 

· Click on one of the columns in the enrichment diagram of set 1. The “Enrichment Info” dialog box will appear.

· In the “Enrichment info” dialog box, click on one of the Gene IDs in the table. 

· Go back to the CLICK 3.1 solution tab. Open the content of one of the enriched clusters by clicking on the corresponding row in the clusters table. The panel on the right now contains an additional tab with the title: CLICK 3.1 TF Enrich.1, which contains the corresponding diagram and information regarding the analysis.

1.8. Saving the session: 
· From the “File” menu, select “Save Session”.

· In the “File Name” field, enter (or browse) the path 

D:/MA Course/ExpanderData/humanSerum_session1.zip and press the “OK” button. 

· Close the session by selecting “Close All” from the “File” menu.

1.9. Loading the saved session:

· Select the “Load Session” option from the “File” menu.

· Use the pull-down arrow in the File Name field to enter the path in which the session has been saved (Expander remembers previous sessions you have worked on), and press the “Ok” button. 

2. Human Huntington's disease brain cells analysis:

In this section, we will analyze a dataset published by Hodges et al (1), in which high-density oligonucleotide array data was used to measure expression profiles from Caudate tissues taken post-mortem from HD patients and non-patients. 

2.1. Loading the data: 

We will load the gene expression data matrix and an ID conversion file. The conversion file maps each Affymetrix probe ID in the data file to its corresponding official gene ID (Entrez-Gene IDs).
· From the “File” menu, select “New Session” ( ”Expression Data” ( “Tabular Data File”.

· In the “Load Study” dialog box, make sure the Organism is set to “Human”. Use the “Browse” buttons to load the expression data file and the ID conversion file from the following directories:  

            Data file: D:/MA Course/ExpanderData/ HDbrain_c.human.txt

 
Conversion file: D:/MA Course/ExpanderData/HGU133P2_affyids2Geneids.txt

· Set the “Data type” to “Oligonucleotide array”.

· Press the “Advanced” button.

· In the “Advanced” Dialog box select “No column specifies gene symbols” and press the “Preview” button.

· Note the change in the data table at the bottom of the “Advanced” dialog.

· Press the “Define condition subsets” button.

· Select all N_ conditions from the list, enter the text “Normal” in the “Group name” field and press the “>>” button. 

· Repeat the previous step for all HD_ condition with the name “Patients”.

· Press “OK” in the “Define Condition Subsets” dialog box. 

· Press “OK” in the “Advanced” dialog box. 

· Press “OK” in the “Load Study” dialog box.

2.2. Filtering the data according to t-test statistics:  

· From the “Preprocessing” menu, select “Filter Probes” ( ”T-tset”.

· Press the “Select” button for the “Group 1 conditions”. 

· In the “Select Conditions” dialog box, check (mark) the “Normal” check box’ and press “OK”. 

· Press the “Select” button for the “Group 2 conditions”. 

· In the “Select Conditions” dialog box, check (mark) the “Patients” check box’ and press “OK”. 

· In the “Filter Criteria” ask for “Select 500 most differential probes”.

· In the bottom section ask for:  “Do not include probes with expression values < 40 in over 50% of both condition groups”.

· Press “Ok”. 

2.3. Performing hierarchical clustering on the data:

· From the “Grouping” menu, select “Hierarchical Clustering”.

· In the dialog box, select “Average” as linkage type. Press the “OK” button.

· Look at the resulting display.

· Use the “Zoom in” and "Zoom out" buttons from tool bar to change zoom, and get a closer or more general view of the expression patterns arranged in the hierarchical clustering order.

2.4. Identifying enriched TF Binding sites within clusters:

· From the “Group Analysis” menu, select “Promoter Analysis” ( “PRIMA”. Note that in the “Promoter Analysis” dialog box the “Filtered Data” is selected as the target set on which analysis is to be performed. Set the p-value threshold to 0.001 and Press the “OK” button. The analysis might take a few minutes. 

· Look at the resulting display. Which TF  binding site enrichments has been detected? 

· Click on one of the columns in the enrichment diagram. The “Enrichment Info” dialog box will appear.

· In the “Enrichment info” dialog box, look for the p-value.  Click on one of the Gene IDs in the table. 

3. Human cell cycle dataset analysis:


In this section, we will analyze a dataset published by Whitfield et al.(2), in which gene expression profiles were recorded during cell-cycle progression in human Hela cells. First, Whitfield et al. identified genes that showed a periodic expression pattern: The expression of some 800 genes was regulated in a cell-cycle dependent manner. Next, Whitfield et al. applied cluster analysis to this set of cell-cycle regulated genes. Five major clusters emerged, corresponding to genes whose expression peaks at G1/S, S, G2/M, M and M/G1 phases of the cell-cycle, respectively. 

Here we will analyze these clusters (without loading the original expression data file). The clustering file contains two columns: the first column contains the gene ID and the second one lists the cluster (set) id.

3.1. Loading the cluster file:

· From the “File” menu select “New Session” ( ”Gene Sets”.

· In the “Load gene sets” dialog box, make sure the organism is set to “Human”. Use the “Browse” buttons to load the gene sets data file from the following location:

Gene Set file: D:/MA Course/ExpanderData/cl.hcc.Human.geneid.txt

· Press the “OK” button.

· Click on the top row (which contains the first cluster). The cluster content is displayed on the right. The “Gene Symbol” column is not available in this analysis, since the data file we loaded contains only Gene IDs and cluster numbers, without the symbols of the genes. 

3.2. Identifying enriched GO categories within clusters:

· From the “Group Analysis” menu, select: “Functional Analysis” ( “TANGO”. 

· At the "Background set" portion of the dialog box, select the "From File" option. Use the “Browse” buttons to load an external background file from the following location:  

            Background file: D:/MA Course/ExpanderData/bg.all.geneids.human.txt

· Press the “OK” button. 

· Look at the resulting display. In which sets (clusters) has functional enrichment been detected? 

· Saving the analysis results into a file: From the “Group Analysis” menu, select “Functional Analysis” ( “Export Results”. 

· In the “Export Functional Analysis Solution” Dialog box, enter the path: D:/MA Course /ExpanderData/hcc.Human.GO.txt and press the “OK” button. 

· Open the directory using Windows Explorer and browse through it to see the content of this output file. 

3.3. Identifying enriched TF Binding sites within clusters:

· From the “Group Analysis” menu, select “Promoter Analysis” ( “PRIMA”. The "Promoter Analysis" dialog box will open. 

· At the "Background set" portion of the dialog box, select the "From File" option. Use the “Browse” buttons to load an external background file from the following location:  

            Data file:  D:/MA Course/ExpanderData/bg.all.geneids.human.txt

· Press the “OK” button. 

· Look at the resulting display. In which sets (clusters) has TF binding sites enrichment been detected? 

· Results can be saved also as an image file: From the “File” menu, select “Save As Image”. A dialog box will appear.

· In the dialog box, select “.jpg” as the file type. Enter the directory path (or use the "Browse" button), to which the images will be saved:  

 D:/MA Course/ExpanderData/

* Note: Do not specify the name of an image, only the name of the folder. Expander will name the images with standard names (Analysis info, Histograms and Color scale).

· Press the “OK” button.

· Open the directory using Windows Explorer and browse through it to see the images. 

3.4. Saving the session: 
· From the “File” menu, select “Save Session”.

· In the “File Name” field, enter (or browse) the path 

D:/MA Course/ExpanderData/hcc_session1.zip and press the “OK” button. 

· Close the session by selecting “Close All” from the “File” menu.

3.5. Loading the saved session:

· Select the “Load Session” option from the “File” menu.

· Use the pull-down arrow in the File Name field to enter the path in which the session has been saved (Expander remembers previous sessions you have worked on), and press the “Ok” button. 
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